Some data in selected reports may be out of date

Incident Report for Timely Limited

Resolved

The reports refresh process has run as expected overnight, and all data in our reports will be up to date.
Posted Jun 04, 2025 - 09:10 NZST

Monitoring

Due to a refresh process in our reports partially failing this morning, some customers may be experiencing an issue with out-of-date data in the following reports:

- Executive Summary
- Future Value
- Appointment Schedule

Some information in your dashboard may have also not refreshed correctly overnight.

We're currently monitoring the process, and we expect this to resolve with the next refresh at 4am NZT.
Posted Jun 03, 2025 - 14:56 NZST
This incident affected: Main System (Timely App).