Scheduled report maintenance in progress
Incident Report for Timely Limited
Resolved
Report maintenance has successfully completed.
Posted Apr 01, 2021 - 07:09 NZDT
Monitoring
Maintenance of our reports system is going as planned, and should be back up and running better than ever very soon.
Posted Apr 01, 2021 - 06:15 NZDT
Investigating
We're currently making our reports faster. There may be some interruption while we complete this work, but we'll have everything back up very shortly.
Posted Apr 01, 2021 - 05:57 NZDT
This incident affected: Main System (Timely App) and Other Services (Online Bookings, Email Sending).