Yesterday we conducted some maintenance and the iOS app is all fixed! We’re actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us. We will continue to monitor closely for the next 24 hours.
Still having issues with Timely or the iOS app? Please reach out to our friendly Support team via https://help.gettimely.com/hc/requests/new and we’ll get back to you shortly.
Posted Dec 19, 2024 - 12:00 NZDT
Identified
We’re making progress! We've identified the issue and have a plan to fix it. We'll be doing some maintenance to resolve it. There might be a slight outage at this time however we expect it to be short (you may need to refresh). This will happen at 7:45pm NZST 5:45pm AEDT 6:45am GMT 1:45am EST 10:45pm PST
Posted Dec 18, 2024 - 17:21 NZDT
Monitoring
We have implemented a fix and the main application is now working at normal speeds. The iOS app is performing much better, but still more slowly than we'd like and we are continuing to work to improve this.
Posted Dec 18, 2024 - 15:41 NZDT
Update
We've made some progress getting the main timely website back online, however the iOS app is still completely down at present. We are hoping to restore service as soon as possible.
Posted Dec 18, 2024 - 15:26 NZDT
Identified
We have identified the where the root of the issue is and our engineering team is all hands on deck working to restore service
Posted Dec 18, 2024 - 15:20 NZDT
Update
We are continuing to investigate this issue.
Posted Dec 18, 2024 - 15:10 NZDT
Investigating
We have numerous reports of Timely running slowly. We are very sorry for the inconvenience, and are actively working to resolve the issue.
Posted Dec 18, 2024 - 15:06 NZDT
This incident affected: Main System (Timely App) and Other Services (Online Bookings, iOS app / API).