Online Booking Degraded Performance
Incident Report for Timely Limited
Resolved
Timely Online Bookings is now back to normal. Sorry for any inconvenience while our tech team worked on this.
Posted Oct 13, 2022 - 21:30 NZDT
Update
We are continuing to actively monitor the situation to ensure this doesn’t happen again. If you have any concerns at all, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Oct 13, 2022 - 17:43 NZDT
Monitoring
We appreciate you keeping an eye on the Timely ‘Status’ Page. Our tech team have identified the issue, and have applied a fix. We are continuing to monitor the situation to ensure this doesn’t happen again. If you have any concerns at all, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Oct 13, 2022 - 16:55 NZDT
Investigating
Timely Online Bookings is taking longer than usual to load today - our apologies! Hang tight, our tech team are working hard to identify the cause of the slowness, and will apply a fix as soon as possible. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Oct 13, 2022 - 16:40 NZDT
This incident affected: Other Services (Online Bookings).