Outage due to upstream network provider
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted Jun 21, 2022 - 22:07 NZST
Monitoring
Our upstream provider has resolved the incident and access has been restored.
Posted Jun 21, 2022 - 22:07 NZST
Investigating
Were seeing widespread slowdowns and issues accessing Timely at present and have been notified by our upstream network provider that they are experiencing a major outage. Timely will be mostly inaccessible until they resolve this issue.
We are expecting an update from them within the next 10 minutes.
Posted Jun 21, 2022 - 19:00 NZST
This incident affected: Main System (Timely App).