SMS Messages sending delayed for some customers
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted Aug 29, 2018 - 07:42 NZST
Investigating
We've had reports from some UK and EU based customers of delays sending SMS messages - we're investigating the issue with our upstream provider and hope to have all SMS messages sent soon. Customers in Australia, New Zealand, US & Canada are unaffected.
Posted Aug 29, 2018 - 03:27 NZST
This incident affected: Other Services (SMS Sending).