Issues with occasional application slowdown

Incident Report for Timely Limited

Resolved

This incident has been resolved.
Posted May 15, 2025 - 09:57 NZST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 14, 2025 - 15:18 NZST

Identified

We're aware of an issue related to parts of Timely that are causing slowdowns occasionally for some of our customers. We've identified the cause and we're currently working to fix this.

We do not currently see widespread impact for our customers.
Posted May 14, 2025 - 10:25 NZST
This incident affected: Main System (Timely App) and Other Services (iOS app / API).