Reports are all fixed! The booking related emails will take a while to clear up. We’re actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.
Our tech team has successfully identified that reports issue has been caused by a slow process in our backend database and are applying a fix as quickly as possible. We’re really sorry if this has caused a hiccup in your day - we’ll have reports back up and running as soon as we can.
Posted Apr 15, 2025 - 22:52 NZST
Investigating
Timely reports and booking related emails are experiencing some degraded performance.
We know this is frustrating. Our tech team is identifying the root cause and is working to resolve this issue with urgency.
If you have any concerns, our Support team is happy to assist - please reach out to https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly. If deemed necessary: We’ve closed our phone lines so the team can respond to the volume of emails coming through. This is a temporary measure during an outage and we thank you for your patience!
Hang tight - we’ll provide updates here every (insert time period here, ideally no more than 30 minutes).
Posted Apr 15, 2025 - 22:10 NZST
This incident affected: Main System (Timely App) and Other Services (Email Sending).