Timely app experiencing some errors
Incident Report for Timely Limited
Resolved
A fix has been applied for this and Pin Switching should now be working for all users.
Posted May 21, 2024 - 15:42 NZST
Identified
We believe any on-going errors are restricted only to our pin entry page, for those who have pin-switching enabled. We've already taken steps to sort this out and are confirming whether it has worked for everyone.
Posted May 21, 2024 - 15:06 NZST
Investigating
After our issues with Timely running slowly earlier today, we've noticed that a small number of users are still having problems accessing some parts of Timely.
Hang tight, our tech team is working hard to identify what’s causing these errors and will apply a fix as soon as possible. If you have any concerns, our support team is happy to assist. Please reach out to us on this form https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.
Posted May 21, 2024 - 14:44 NZST
This incident affected: Main System (Timely App).