Degraded performance in Timely applications

Incident Report for Timely Limited

Resolved

Good news, the issue of degraded performance for some customers is now resolved! Timely will be working as expected. If you notice something seems off, or you have further questions, our support team is always happy to hear from you. Reach out to us at this form https://help.gettimely.com/hc/en-gb/requests/new. We know it’s frustrating when Timely is slow to load, and we’re sorry for any disruption we may have caused. Thanks for your patience!
Posted Apr 09, 2026 - 17:46 NZST

Monitoring

We’ve experienced degraded performance in Timely application between 3:30pm - 5:00pm NZST. We have identified the challenge and have put the potential fix in. We are actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.
Is Timely still running slowly for you? Please reach out to our friendly Support team via this form https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.
Posted Apr 09, 2026 - 17:23 NZST
This incident affected: Main System (Timely App).