TimelyPay Terminals cannot be paired with iPad for some users
Incident Report for Timely Limited
Resolved
Good news, the issue with the Timely app on iPads is now resolved and everything should be working as expected!

In version 2.15.7 of the app, we accidentally introduced a bug that caused the application to crash on an iPad when accessing the Terminal settings screen. The most impacted users were those needing to use this screen to pair a terminal to their iPad and process payments. The team has fixed the bug in a new version of the app. Users can resolve the issue by updating their Timely iOS app to 2.15.8.

We know disruptions like this can be frustrating, and we appreciate your patience.

If you notice something seems off, or you have further questions, our support team is always happy to hear from you. Reach out to us at https://help.gettimely.com/hc/en-gb/requests/new.
Posted Aug 08, 2024 - 18:36 NZST
Monitoring
Great news! A new version of the Timely iOS app has been released. Please make sure you update to version 2.15.8.

With this release, users can now access the Terminal settings page in the Timely app on an iPad, and will be able to pair a terminal. We're actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.

Still having issues with the Timely app on iPad? Please reach out to our friendly Support team via https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.
Posted Aug 08, 2024 - 18:26 NZST
Update
We're making progress!
Our tech team has successfully identified an app crash occurring when navigating to the TimelyPay settings on an iPad running Timely version 2.15.7 and are applying a fix as quickly as possible. We're really sorry if this has caused a hiccup in your day - we'll have an updated version of the app, 2.15.8, available in the Apple app store as soon as we can. This is already with Apple waiting for approval.

In the meantime, if you are a touchscreen terminal user, you may continue taking payments via the Timely web app. If you are a mini-terminal user, it's possible that your terminal will automatically reconnect and you will be able to continue taking payments uninterrupted. If your connection is not re-established, a temporary workaround is to pair the mini-terminal to an iPhone if available.

If you're on Timely version 2.15.6, this will not affect you.

We will provide another update once we hear back from Apple.
Posted Aug 08, 2024 - 12:02 NZST
Identified
We are aware of an issue affecting some iPad users. Navigating to the TimelyPay connection settings on an iPad running version 2.15.7 causes the app to crash affecting a maximum of 888 customers. This may prevent customers from manually pairing a TimelyPay terminal.
Posted Aug 08, 2024 - 11:56 NZST
This incident affected: Other Services (iOS app / API).