Slowness for some users
Incident Report for Timely Limited
Resolved
This incident has been resolved
Posted Jun 05, 2024 - 14:03 NZST
Monitoring
We've beefed up our capacity and Timely has been running smoothly at full speed for the past 25 minutes.
We're continuing to proactively monitor and ensure that nothing causes these issues to return.
Posted Jun 05, 2024 - 13:41 NZST
Identified
We've identified the source of the issue and have added some extra processing power to get Timely back up and running more quickly. This seems to be helping so we're hopeful that we will be back to full speed soon
Posted Jun 05, 2024 - 13:22 NZST
Investigating
As of 12pm NZ Time, Timely is taking longer than usual to load today for some of our customers - our apologies, we know this isn’t ideal!

Hang tight, our tech team is working hard to identify what’s causing this slowness and will apply a fix as soon as possible. If you have any concerns, our support team is happy to assist. Please reach out to us on this form https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.

Otherwise, we’ll keep you updated on our progress here every 20 minutes
Posted Jun 05, 2024 - 13:07 NZST
This incident affected: Main System (Timely App).