Slowdown in calendar

Incident Report for Timely Limited

Resolved

We are happy to report that this issue is now resolved! Thank you for hanging in there with us. By now you will have noticed your Timely performing normally, as expected. Our Support team are always happy to hear from you, so if you have any further questions, please reach out to us at help@gettimely.com.
Posted Oct 17, 2022 - 12:35 NZDT

Monitoring

Fixes have all been applied and systems are back online. We're monitoring those fixes to ensure the applications are fixed. Our sincere apologies for any inconvenience caused. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Oct 17, 2022 - 12:15 NZDT

Update

We've applied fixes and The Timely App is starting come back to normal. We are still waiting to bring Online Bookings and Mobile back online, but should return in the next minute or two
Posted Oct 17, 2022 - 12:12 NZDT

Identified

We’re making progress! Our tech team have successfully identified the issue, and are working hard to apply a fix as quickly as possible. Our sincere apologies for any inconvenience caused
Posted Oct 17, 2022 - 11:49 NZDT

Update

We are continuing to investigate this issue.
Posted Oct 17, 2022 - 11:47 NZDT

Investigating

Investigating

Timely is currently experiencing a temporary slow down. Rest assured, our tech team are working hard to identify the cause of the issue, and apply a fix as quickly as possible. Our sincere apologies for any inconvenience caused. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Oct 17, 2022 - 11:43 NZDT
This incident affected: Main System (Timely App) and Other Services (Online Bookings, iOS app / API).