Slow or unresponsive invoicing workflows

Incident Report for Timely Limited

Resolved

The change to address this fault has been successfully applied.
Posted Mar 31, 2026 - 08:34 NZDT

Monitoring

A fix has been deployed and we will continue monitoring to ensure the issue has been resolved.
Posted Mar 30, 2026 - 15:11 NZDT

Update

We are deploying the change to revert an earlier update to Timely's invoicing workflows which has led to further, subsequent failures for other related systems. The release task is expected to take up to 15 minutes. We will provide a further update within the next 30 minutes once this task has been completed.
Posted Mar 30, 2026 - 14:24 NZDT

Update

We are planning to release a change that aims to fix a missing value from our back end systems. We will deploy this as soon as we've verified that it can be made without adding further disruption.
Posted Mar 30, 2026 - 13:38 NZDT

Identified

We have identified a problem with our invoicing workflows that is impacting some customers ability to access their customer profile page in Timely and to process invoices and payments. We have identified the cause of the issue and are implementing a fix. We will update this page in another 30 minutes.
Posted Mar 30, 2026 - 13:11 NZDT
This incident affected: Main System (Timely App) and Other Services (iOS app / API).