Timely Outage
Incident Report for Timely Limited
Resolved
The fix has been working well and everything has been stable for the past 20 minutes.
Posted Aug 09, 2024 - 16:52 NZST
Monitoring
We have applied a fix and Timely is now performing much better - we will continue to monitor closely
Posted Aug 09, 2024 - 16:39 NZST
Identified
As of 4.15pm New Zealand Time, Timely is experiencing a temporary outage, which means all customers will notice Timely running slowly at this time. We know this is frustrating. Our tech team is identifying the root cause and is working to resolve this issue with urgency.

If you have any concerns, our Support team is happy to assist - please fill in the form here - https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.

Hang tight - we’ll provide updates here every 10 minutes, as we have already begun to make progress towards resolving the issue.
Posted Aug 09, 2024 - 16:35 NZST
Investigating
We are currently investigating a problem with Timely running very slowly for most users
Posted Aug 09, 2024 - 16:31 NZST
This incident affected: Main System (Timely App).