Good news, the issue with Reporting service is now resolved! Timely will be working as expected. If you notice something seems off, or you have further questions, our support team is always happy to hear from you. Reach out to us at this form Submit a request – Timely .Our support phone lines are open again, too.
We know outages are inconvenient and we’re sorry for any disruption we may have caused.
Posted Sep 23, 2026 - 18:00 NZST
Update
We are continuing to monitor for any further issues.
Posted Sep 23, 2026 - 17:58 NZST
Monitoring
Reporting service is back online! We’ve applied a fix and are actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.
Still can’t access Timely? Please reach out to our friendly Support team via this form here Submit a request – Timely and we’ll get back to you shortly.
Posted Sep 23, 2026 - 17:58 NZST
Identified
We have identified a fault with our reporting service that has impacted customer reporting functions in the app. We are working to restore services as quickly as possible.