Issues synchronising invoices to Xero
Incident Report for Timely Limited
Update
We've restored the majority of functionality to synchronising invoices to Xero. At this point in time most customers should see their invoices automatically synchronising with Xero! We’re actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.

Invoices created between 12:00pm and 4:45pm NZT may not have been synchronised with Xero. In the meantime, these can be manually synchronised using the 'Sync to Xero' functionality on the invoice screen in Timely. See https://help.gettimely.com/hc/en-gb/articles/360062955453-How-to-manually-sync-invoices-to-Xero for more information. Rest assured that the tech team is looking into sorting this out for you and we hope to have an update in the next 24 hours.

Still having issues with invoices or payments not appearing in Xero? Please reach out to our friendly Support team via https://help.gettimely.com/hc/requests/new and we’ll get back to you shortly.
Posted Nov 21, 2024 - 16:45 NZDT
Update
We’re making progress!

Our tech team has successfully identified that problems synchronising invoices with Xero has been caused by a change we made to improve the security of the application and are applying a fix as quickly as possible. We’re really sorry if this has caused a hiccup in your day - we’ll have invoice synchronisation with Xero back up and running as soon as we can.
Posted Nov 21, 2024 - 15:30 NZDT
Identified
We've identified an issue where invoices created in Timely aren't automatically synchronising with the accounting package Xero - our apologies, we know this isn’t ideal!

Hang tight, our tech team is working hard to identify what’s causing this and will apply a fix as soon as possible. If you have any concerns, our support team is happy to assist. Please reach out to us on this form https://help.gettimely.com/hc/requests/new and we’ll get back to you shortly.

Otherwise, we’ll keep you updated on our progress here every hour or so.
Posted Nov 21, 2024 - 14:45 NZDT
This incident affects: Other Services (Integrations / Webhooks).