Calendar unavailable to some users
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted Aug 03, 2024 - 11:24 NZST
Monitoring
A fix has been applied and we are monitoring the results.
Posted Aug 03, 2024 - 10:22 NZST
Identified
A recent change ahead of UK SMS compliance has impacted some businesses mainly based in the UK and northern Americas. A fix is being implemented.
Posted Aug 03, 2024 - 09:32 NZST
Investigating
We are receiving reports from customers unable to access their calendar. This issue appears to be affecting users of the new Timely beta version of the calendar only based on the reports we're receiving. We are investigating the cause of this issue and will provide updates here as we work to identify the cause.
Posted Aug 03, 2024 - 07:58 NZST
This incident affected: Main System (Timely App).