Problems creating bookings

Incident Report for Timely Limited

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 11:28 NZST

Monitoring

We've found and fixed the problem and can see that all bookings are being created successfully now. We're very sorry for any inconvenience caused and will continue to monitor extra closely to be sure that everything is running well.
Posted Jun 24, 2025 - 11:19 NZST

Investigating

We are investigating a problem preventing some new bookings from being made and are working fast to get this resolved
Posted Jun 24, 2025 - 11:08 NZST
This incident affected: Main System (Timely App) and Other Services (Online Bookings).