Timely is experiencing issues
Incident Report for Timely Limited
Resolved
We are happy to report that this issue is now resolved! Thank you for hanging in there with us. By now you will have noticed your Timely performing normally, as expected. Our Support team are always happy to hear from you, so if you have any further questions, please reach out to us at help@gettimely.com.
Posted Nov 08, 2022 - 15:35 NZDT
Investigating
Timely is taking a longer than usual to load today - our apologies! Hang tight, our Techbot team are working hard to identify the cause of the slowness, and will apply a fix as soon as possible. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Nov 08, 2022 - 14:25 NZDT
This incident affected: Other Services (Online Bookings, iOS app / API) and Main System (Timely App).