Timely has now been running smoothly for all customers for at least the last 30 minutes and we are confident the problem has been resolved. If you notice something seems off, or you have further questions, our support team is always happy to hear from you.
We know it’s frustrating when Timely is slow to load, and we’re sorry for any disruption we may have caused. Thanks for your patience!
Posted May 21, 2024 - 12:07 NZST
Monitoring
Our tech team is working hard to diagnose and resolve this issue and have already made great progress in getting things running quickly again. We're monitoring closely to ensure it doesnt get worse again.
Posted May 21, 2024 - 11:46 NZST
Investigating
As of 10.45 (NZ Time), Timely is taking longer than usual to load today for most customers - our apologies, we know this isn’t ideal!
Hang tight, our tech team is working hard to identify what’s causing this slowness and will apply a fix as soon as possible. If you have any concerns, our support team is happy to assist. Please reach out to us on this form https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.
Otherwise, we’ll keep you updated on our progress here in 10 minutes as we believe it is already starting to improve.