Marketing Website Down

Incident Report for Timely Limited

Resolved

This incident has been resolved.
Posted May 26, 2026 - 23:00 NZST

Investigating

We are currently experiencing an issue affecting our marketing website, which is unavailable at this time. Our team is actively investigating the cause and working to restore service as quickly as possible.

We will provide further updates as more information becomes available.
Posted May 26, 2026 - 22:40 NZST
This incident affected: Other Services (Company Website).