Inconsistent Application Availability

Incident Report for Timely Limited

Resolved

This was an internal configuration issue and had no impact on Timely customers.
Posted Apr 09, 2026 - 13:23 NZST

Investigating

We are aware of some connections to the main Timely failing, with an "Application Error" page being presented instead. This issue appears to be periodic and not wide-spread. We are investigating to see what possible areas may be at fault.
Posted Apr 09, 2026 - 13:12 NZST
This incident affected: Main System (Timely App).