Dashboards aren't working

Incident Report for Timely Limited

Resolved

This incident has been resolved. Dashboards are now working again.
Posted Jul 02, 2025 - 16:40 NZST

Investigating

We are investigating a problem with our dashboards in Timely and are aware that customers will not be able to see them.
Posted Jul 02, 2025 - 16:27 NZST
This incident affected: Main System (Timely App).