Partial Outage
Incident Report for Timely Limited
Resolved
All systems are now operating at full capacity again. We'll continue to monitor closely and work continuously to ensure this does not reoccur in the future
Posted Aug 18, 2022 - 13:53 NZST
Investigating
Timely is currently experiencing a temporary slowdown and partial outage. Rest assured, our tech team are working hard to identify the cause of the issue, and apply a fix as quickly as possible. Our sincere apologies for any inconvenience caused. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Aug 18, 2022 - 13:24 NZST
This incident affected: Main System (Timely App) and Other Services (Online Bookings, Email Sending, SMS Sending, Help Resources, Company Website, iOS app / API, Integrations / Webhooks).