Delayed SMS Delivery for UK + EU Customers
Incident Report for Timely Limited
Resolved
Our SMS provider has reported that this incident has been resolved, and SMS are now being delivered as expected.
Posted Nov 30, 2020 - 08:54 NZDT
Monitoring
We are happy to report that our service provider has provided a fix. We are continuing to monitor the situation to ensure this doesn’t happen again. If you have any concerns at all, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Nov 29, 2020 - 00:22 NZDT
Investigating
SMS from Timely are taking a while to send out today - our apologies! Hang tight, our tech team are working hard to identify the cause of the delay and will apply a fix as soon as possible. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Nov 28, 2020 - 02:26 NZDT