Delays in Email and SMS sending

Incident Report for Timely Limited

Resolved

Our fix is working well and all email and SMS sending is back to full speed.
Posted May 14, 2025 - 04:34 NZST

Update

SMS sending is now back up to full speed, however there is still a backlog of emails to get through as our system catches up.
Posted May 14, 2025 - 03:49 NZST

Identified

We have found out why these messages are slow to send and are working to resolve this as soon as possible.
Posted May 14, 2025 - 03:39 NZST

Investigating

We are investigating slower than normal SMS and Email sending times. We are very sorry for the inconvenience and are doing everything we can to get these important messages sending on time.
Posted May 14, 2025 - 03:24 NZST
This incident affected: Other Services (Email Sending, SMS Sending).