Timely app outage
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted Mar 29, 2019 - 09:02 NZDT
Monitoring
A fix has been implemented and we are monitoring the results
Posted Mar 29, 2019 - 08:08 NZDT
Identified
The Timely web app is currently down. The team is currently working on restoring it as soon as possible. Next update soon.
Posted Mar 29, 2019 - 08:02 NZDT
This incident affected: Main System (Timely App).