Delays to SMS messages across all regions

Incident Report for Timely Limited

Resolved

This incident has been resolved.
Posted Oct 07, 2025 - 14:53 NZDT

Investigating

We are experiencing delays with SMS messages being successfully sent / received across all regions.

Currently, SMS are still sending, however at a delayed rate.

We are currently investigating a solution and will update as soon as we know more.
Posted Oct 07, 2025 - 14:20 NZDT
This incident affected: Other Services (SMS Sending).