Timely experiencing issues
Incident Report for Timely Limited
Resolved
Timely is operating normally and there have been no further issues. Thanks for your patience.
Posted Aug 15, 2018 - 16:38 NZST
Monitoring
We appreciate you keeping an eye on the Timely ‘Status’ Page. Our tech team have identified the issue, and have applied a fix. We are continuing to monitor the situation to ensure this doesn’t happen again. If you have any concerns at all, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Aug 15, 2018 - 13:59 NZST
Investigating
Timely is currently experiencing a few issues which means some customers could be impacted. We are working on resolving this issue as quickly as possible. Please accept our apologies for any inconvenience this has caused.

Keep an eye on this page and contact support at: help@gettimely.com if you have any concerns.
Posted Aug 15, 2018 - 13:22 NZST