Timely is experiencing issues

Incident Report for Timely Limited

Resolved

This incident has been resolved.
Posted Jun 11, 2025 - 08:50 NZST

Monitoring

We appreciate you keeping an eye on the Timely ‘Status’ Page. Our tech team have identified the issue, and have applied a fix. We are continuing to monitor the situation to ensure this doesn’t happen again.
Posted Jun 10, 2025 - 16:41 NZST

Investigating

We are currently investigating some degraded performance with the cash-up feature.
You may experience slowness or inability to close the register when performing a cash-up.
Posted Jun 10, 2025 - 16:11 NZST
This incident affected: Main System (Timely App).