Updating staff with third party integrations failing

Incident Report for Timely Limited

Resolved

We are happy to report that this issue is now resolved! Thank you for hanging in there with us. By now you will have noticed your Timely performing normally, as expected. Our Support team are always happy to hear from you, so if you have any further questions, please reach out to us at https://help.gettimely.com/hc/en-gb
Posted Nov 21, 2025 - 11:42 NZDT

Monitoring

The fix has been implemented, and we're continuing to monitor.
Posted Nov 21, 2025 - 11:35 NZDT

Identified

We've identified the issue with a recent update to the staff page, and a fix is being implemented
Posted Nov 21, 2025 - 11:05 NZDT

Investigating

We've identified an issue with a recent update to the staff page is causing errors when attempting to save any changes.

This only affects staff members with third party calendar integrations.
Posted Nov 21, 2025 - 11:00 NZDT
This incident affected: Main System (Timely App).