Beta Calendar - Live updates not refreshing
Incident Report for Timely Limited
Resolved
We can confirm this incident was resolved at 8:55 NZT this morning. We've identified the root cause and have fixes coming to prevent this happening again.

Our apologies for this.
Posted Nov 08, 2024 - 08:55 NZDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 07, 2024 - 16:42 NZDT
Investigating
We're currently investigating an issue with our Beta Calendar's live updates functionality.

Live updates have been failing since ~2:45 PM NZDT.

In the meantime, you can either refresh your web browser to update Calendar manually, or can toggle back to our Old Calendar via the user profile menu on the top right of the web application.
Posted Nov 07, 2024 - 16:00 NZDT
This incident affected: Other Services (Online Bookings).