Timely web app performance impact
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted Apr 30, 2019 - 17:57 NZST
Monitoring
The Timely app has been stable for the last 30 mins but we are continuing to monitor.
Posted Apr 30, 2019 - 15:56 NZST
Investigating
We are investigating an issue that is causing application slowness for a subset of customers. Apologies if this is causing you any inconvenience, rest assured our tech team are investigating and will carry out steps to get things back to normal.
Posted Apr 30, 2019 - 14:49 NZST
This incident affected: Main System (Timely App).