Help docs temporarily unavailable
Incident Report for Timely Limited
Resolved
Help docs are back so feel free to jump back in: http://help.gettimely.com Apologies for any inconvenience.
Posted Feb 17, 2020 - 17:41 NZDT
Identified
The cause has now been identified by our partner and a solution is actively being worked on.
Posted Feb 17, 2020 - 16:51 NZDT
Investigating
Hey there folks, our help docs are currently offline. The cause is currently being investigated but we expect them to be right back shortly.
Posted Feb 17, 2020 - 16:31 NZDT
This incident affected: Other Services (Help Resources).