Timely iOS app degraded for some customers

Incident Report for Timely Limited

Monitoring

The application version including the fix of the login issue for a small portion of our iOS (iPhone/iPad) users is available now! Please update to the latest version of the iOS app if you previously experience the issue.

We’re actively monitoring the system to ensure the fix is working as expected. Thanks for bearing with us.

Still having issues with iOS app, please reach out to our friendly Support team via https://help.gettimely.com/hc/en-gb/requests/new and we’ll get back to you shortly.
Posted Feb 13, 2026 - 08:38 NZDT

Update

We’re making more progress!

Our team has identified the problem, applied the fix, and submitted the iOS application required review to Apple Store.
This review process can take up some time. We’ll continue to monitor closely and will provide another update as soon as the review is completed.

We’re really sorry for this interruption to your day - we’ll have you back up and running as soon as we can.
Posted Feb 10, 2026 - 16:17 NZDT

Identified

We’re making progress!

Our tech team has successfully identified that iOS app change would cause the issue and are applying a fix as quickly as possible.

We’re really sorry if this has caused a hiccup in your day, our Support team are happy to assist - please reach out to https://help.gettimely.com/hc/en-gb instead and we’ll get back to you shortly.
Posted Feb 10, 2026 - 10:14 NZDT

Investigating

Our Techbot team are currently investigating an issue preventing login for a small portion of our iOS (iPhone/iPad) users.

If you have any concerns, our Support team are happy to assist - please reach out to https://help.gettimely.com/hc/en-gb instead and we’ll get back to you shortly.
Posted Feb 09, 2026 - 12:28 NZDT
This incident affects: Other Services (iOS app / API).