Issues with reports
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted about 2 years ago. Apr 26, 2016 - 19:33 NZST
Identified
Our report server is throwing a wobbly which is causing some slowness. We should have this sorted in a jiffy.
Posted about 2 years ago. Apr 26, 2016 - 19:30 NZST