SMS message delays
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted almost 2 years ago. Nov 11, 2016 - 08:55 NZDT
Monitoring
We are currently fixing an issue with SMS message sending. We expect normal SMS sending to resume in approx one hour.
Posted almost 2 years ago. Nov 11, 2016 - 07:49 NZDT