App performance slowness
Incident Report for Timely Limited
Resolved
The performance issues have now been resolved. Apologies for any inconvenience.
Posted almost 2 years ago. Aug 30, 2016 - 13:50 NZST
Investigating
We are investigating current slowness with the app. The Techbots are looking into it and busily working on the underlying issue. Stay tuned for updates.
Posted almost 2 years ago. Aug 30, 2016 - 12:48 NZST