Dashboard not up-to-date
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted 6 months ago. Nov 27, 2017 - 12:23 NZDT
Identified
We have identified an issue where the dashboard is approximately 8 hours out-of -date. A fix for this will go out shortly.
Posted 6 months ago. Nov 27, 2017 - 07:21 NZDT