Google calendar syncing
Incident Report for Timely Limited
Resolved
Google calendar sync is back to normal.
Posted Jul 02, 2018 - 23:24 NZST
Monitoring
We've noticed that Google calendar syncing is slower than usual today. The good news is that the Techbots have looked under the hood and as a result, syncing to Google Calendar will be caught up shortly. Apologies for any inconvenience.
Posted Jul 02, 2018 - 15:58 NZST