Delayed SMS Delivery for UK + EU Customers
Incident Report for Timely Limited
Resolved
Our SMS Provider for the region has investigated and report that SMS are now being delivered as expected.
Posted Nov 24, 2020 - 12:20 NZDT
Update
The issue has been found with a single SMS route provider in the UK + EU region and the issue has been escalated to them for investigation.
Posted Nov 20, 2020 - 08:50 NZDT
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 20, 2020 - 08:48 NZDT
Investigating
There is currently a delay in delivery of one to two hours for some SMS messages in the UK and EU.

The cause of the delay is currently being investigated by our SMS provider for the region.
Posted Nov 20, 2020 - 04:57 NZDT
This incident affected: Other Services (SMS Sending).