Slow down and errors
Incident Report for Timely Limited
Resolved
We're confident everything is back up and running normally
Posted Mar 16, 2022 - 15:25 NZDT
Monitoring
We have applied some mitigations with our cloud service provider and our monitoring tools indicate that the situation has improved considerably. We will continue to monitor closely and look for a route cause.
Posted Mar 16, 2022 - 14:58 NZDT
Update
Our platform/engineering teams are looking into reports of poor performance and errors from some of our customers and are actively looking to rectify the situation.

We believe we have identified the cause of the issue and are applying mitigations
Posted Mar 16, 2022 - 14:52 NZDT
Update
We are continuing to investigate this issue.
Posted Mar 16, 2022 - 14:51 NZDT
Investigating
We are currently investigating this issue.
Posted Mar 16, 2022 - 14:50 NZDT
This incident affected: Main System (Timely App).