Timely performance issues
Incident Report for Timely Limited
Resolved
All systems are now fully operational and we are happy with the performance.
We will continue to keep a close eye on things throughout the day and will do a thorough review of the incident to ensure it does not happen again
Posted Aug 10, 2022 - 12:42 NZST
Monitoring
We've got some positive indications from our further mitigations on the iOS app and all systems are showing signs of improving.
For any users who received a message saying their account was locked out for 30 minutes - this was a symptom of the app being down and is not true, user accounts should be able to log in on the web app and again on iOS when service is restored.
Posted Aug 10, 2022 - 12:34 NZST
Identified
We're applying mitigations to the iOS app in particular - we'd recommend using the Web App for now which is now returning calendar data reliably
Posted Aug 10, 2022 - 12:19 NZST
Update
We are still noticing some issues loading the calendar for some users so are continuing to look for mitigations to apply
Posted Aug 10, 2022 - 12:11 NZST
Update
Our mitigations have been overly affective, with only a few systems still experiencing slowdowns. The main Timely App appears to be performing as per normal but the iOS app may be slower than normal
Posted Aug 10, 2022 - 12:02 NZST
Monitoring
Our mitigations are having a positive impact and some services are beginning to come back online but there may still be some services affected. We are continuing to monitor closely.
Posted Aug 10, 2022 - 11:48 NZST
Update
We have applied some mitigations and are once the performance bottleneck has reduced we will monitor - service is still affected for now but we're hopeful that it will improve in the next few minutes
Posted Aug 10, 2022 - 11:44 NZST
Identified
We have identified the issue causing performance problems and are working on rolling back some changes to restore service.
Posted Aug 10, 2022 - 11:38 NZST
Update
We are continuing to investigate this issue.
Posted Aug 10, 2022 - 11:34 NZST
Investigating
Timely is currently experiencing a temporary outage. Rest assured, our tech team are working hard to identify the cause of the issue, and apply a fix as quickly as possible. Our sincere apologies for any inconvenience caused. If you have any concerns, our Support team are happy to assist - please reach out to help@gettimely.com and we’ll get back to you shortly.
Posted Aug 10, 2022 - 11:32 NZST
This incident affected: Other Services (Online Bookings, iOS app / API, Integrations / Webhooks) and Main System (Timely App).