eWay payment processing issues
Incident Report for Timely Limited
Resolved
New transactions are now processing via eWay again. If you received a failed transaction during this issue you should get in touch with the related customers and ask them to retry their payment details.
Posted Oct 09, 2019 - 11:35 NZDT
Investigating
We are currently investigating an issue with eWay - this is a payment provider used by a small number of our customers to take payments and deposits from their clients. Payments placed through eWay are currently being declined
Posted Oct 09, 2019 - 09:46 NZDT
This incident affected: Main System (Timely App).