Degraded performance on some services
Incident Report for Timely Limited
Resolved
Normal service has been resumed and delayed messages are in the process of being sent. Thanks for your patience and we'll continue to keep an eye on the situation.
Posted Sep 08, 2022 - 18:14 NZST
Identified
We're currently experiencing degraded performance of a process that's impacting our ability to send email and SMS quickly as well as preventing services such as Xero, Mailchimp, etc. receiving data. We're currently working on measures to get through the backlog of queued requests and will keep you notified here.
Posted Sep 08, 2022 - 16:38 NZST
This incident affected: Other Services (Email Sending, SMS Sending, Integrations / Webhooks).