Application slowness
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted May 12, 2020 - 18:55 NZST
Update
We are continuing to investigate this issue.
Posted May 12, 2020 - 13:15 NZST
Investigating
We are currently seeing extreme levels of traffic through the Timely platform which is resulting in slower than usual performance. We are carrying out mitigation steps and apologise for any inconvenience.
Posted May 12, 2020 - 12:45 NZST
This incident affected: Other Services (Online Bookings) and Main System (Timely App).