Issues accessing Timely app and online bookings
Incident Report for Timely Limited
Resolved
There has been no further occurrence of the issues that affected the app this morning.
Posted Mar 05, 2018 - 14:36 NZDT
Monitoring
Access to the web app and online bookings has now been restored.
Posted Mar 05, 2018 - 11:28 NZDT
Investigating
We are currently investigating performance issues with the Timely web app and online bookings. We will keep you updated via this status page.
Posted Mar 05, 2018 - 11:24 NZDT