App slowness
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted almost 2 years ago. Feb 25, 2016 - 16:12 NZDT
Identified
We are diagnosing some slowness in the app and hope to have things back to normal soon.
Posted almost 2 years ago. Feb 25, 2016 - 15:58 NZDT