Multiple SMS being delivered in NZ
Incident Report for Timely Limited
Resolved
This incident has been resolved.
Posted almost 2 years ago. May 11, 2016 - 14:23 NZST
Monitoring
Messages are now sending again, it may take 10 minutes to clear the backlog.
Posted almost 2 years ago. May 11, 2016 - 11:46 NZST
Investigating
We are getting reports of duplicate SMS being delivered to customer handsets in NZ. We are working with our SMS provider to resolve the issue and in the meantime we have stopped further SMS from being delivered.

Note: your SMS credit balance will not be debited for any duplicate SMS.
Posted almost 2 years ago. May 11, 2016 - 10:59 NZST